Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 06, 2026 - 07:00 CDT
Scheduled
Yello will be performing scheduled maintenance on the production environments for Yello Enterprise and Yello Government Recruiting Solutions on Saturday, June 6, 2026.
What to expect: * No downtime is expected for this maintenance * Users accessing sites in these environments during the maintenance window may be logged out during the window and any unsaved changes may be lost * Candidate forms, candidate applications, and integrations will not be affected * Yello Sourcing will not be impacted * After the maintenance window, users may need to log back in
Need help? If you have trouble signing in after the maintenance window, start by clearing your cache and cookies. For further assistance, contact us at support@yello.co.
Posted Jun 05, 2026 - 09:38 CDT
This scheduled maintenance affected: Yello Enterprise (Yello Enterprise Production - US, Yello Enterprise Production - EU), Yello Government Recruiting Solutions (Yello Government Recruiting Solutions (YGRS) Production), and Mobile Apps (Yello Pro).