Yello Enterprise Production (EU) - Temporary Disruption of Object Uploads

Incident Report for Yello

Resolved

All failed jobs have been rerun. The incident has been resolved.
Posted Feb 09, 2026 - 10:29 CST

Monitoring

The access keys have been successfully updated and we are now working to retry all failed jobs. Any newly initiated functions will work as expected.
Posted Feb 09, 2026 - 10:04 CST

Identified

During our routine access key rotation for security compliance, the access keys for our EU Production environment failed to update. This has impacted a range of functions including, but not limited to: uploading/downloading documents, exporting data, candidates completing video interviews, and submitting applications. We are working to resolve this as soon as possible and will retry any failed jobs once resolved.
Posted Feb 09, 2026 - 09:42 CST
This incident affected: Yello Enterprise (Yello Enterprise Production - EU).